0246 – Dica : Nomes de planilha

Você conhece ou utiliza nomes de planilha?

A forma mais fácil de criar um intervalo nomeado, é selecionando o conjunto de células do intervalo e inserindo o nome desejado na caixa de nomes. Exemplo: para chamar o intervalo A1:A10 de MeuIntervalo, selecione as células, digite MeuIntervalo na caixa de nomes e pressione ENTER.

Desta forma você pode digitar o nome do intervalo em fórmulas, ao contrário da referência do intervalo. Ou seja, ao invés de =SOMA(A1:A10), pode fazer =SOMA(MeuIntervalo).

0246_01

 

 

 

Se quiser selecionar um intervalo nomeado, basta digitar o nome do intervalo na caixa de nomes.

 

 

 

Nas versões mais recentes do Excel, na Aba Fórmulas da Faixa de Opções, fica a seção Nomes Definidos a partir da qual pode ser feita a gestão dos nomes da Pasta de Trabalho.0246_02

Por meio do botão Gerenciador nomes é possível Inserir, Excluir e Editar intervalos nomeados além de poder visualizar os nomes da Pasta de Trabalho.

 

0246_03

Um detalhe importante é o Escopo: um nome pode ter escopo de Pasta de Trabalho, de forma que será reconhecido em qualquer uma das planilhas do arquivo, ou escopo de Planilha só sendo reconhecido na planilha no qual foi criado. Esse detalhe é importante quando temos muitos intervalos, ou copiamos planilhas numa Pasta de Trabalho, pois é preciso ficar atento para a forma que os nomes serão utilizados.

Outra opção desta seção é botão, Definir Nome.0246_06

Através dele podemos aplicar nomes em fórmulas, sem a necessidade de editá-la manualmente.

Colocamos em C1 a fórmula =SOMA(A1:A10) e queremos substituir por =SOMA(MeuIntervalo). Selecionamos então C1 e vamos à opção Aplicar Nomes, em Definir Nomes.

0246_08

Fazendo isso observe que o intervalo foi substituído pelo correspondente intervalo nomeado.

0246_09

0246_10

 

A opção Usar em Fórmula permite acessar a lista de nomes disponíveis enquanto estamos digitando uma fórmula, ou colar uma lista dos nomes e respectivas referências numa planilha.

 

0246_11

 

O botão Criar a partir da Seleção é útil para criação de vários nomes rapidamente.

Veja no exemplo a seguir como podemos rapidamente nomear as linhas e colunas da tabela com valores.

0246_12

Abaixo colamos uma lista dos nomes para demonstrar como se referem às linhas e às colunas da tabela.

0246_13

Espero que tenham apreciado e passem a fazer uso de mais esse recurso do Excel:

0010-Criando intervalos dinâmicos

0011-Gráficos x Intervalos Dinâmicos – Parte 1

0015-Gráficos x Intervalos Dinâmicos – Parte 2

0065-Criando constantes e variáveis por meio de intervalos nomeados

 

 

 

 

 

Anúncios

In Excel We Trust

Publicado em Excel
Um comentário em “0246 – Dica : Nomes de planilha
  1. jose disse:

    dá jeito. Obrigado

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 2,074,858

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.536 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: