0230 – Traduzindo fórmulas do Português para o Inglês

Você está num aperto por que seu Excel é em português e precisa traduzir uma fórmula para o inglês?

Experimente essa função personalizada:

Function TRADFORMINGL(rng As Range) As String

    TRADFORMINGL= rng.Formula
        
End Function

Na verdade ela traduzirá a fórmula escrita no idioma de instalação do Excel sempre para o inglês.

Se a fórmula que deseja traduzir estiver na célula A1, a sintaxe é =TRADFORMINGL(A1).

Exemplo:
Se em A1 tivermos =PROCV(B1;D1:G1000;SE(B1>10;2;SE(B1>20;3;4));FALSO), a fórmula =TRADFORMINGL(A1), retornará =VLOOKUP(B1,D1:G1000,IF(B1>10,2,IF(B1>20,3,4)),FALSE)

Se tiver dúvidas em como utilizar uma função personalizada, leia o artigo 0229 – Funções Personalizadas no Excel (UDF)

0029-Funções Personalizadas para Texto

0229 – Funções Personalizadas no Excel (UDF)

In Excel We Trust

Marcado com: , , , , , , ,
Publicado em Excel, Nível: Intermediário

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 1,963,899

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.476 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: