0215-Dica sobre fórmulas: Trabalhando com PROCV e CORRESP em conjunto

Ninguém discute que a função PROCV é extremamente útil para realizar pesquisas.

Mas ela tem um pequeno problema: o número correspondente à coluna cujo valor será retornado.
Ex: =PROCV(A2;$J$2:$L$100;2;FALSO)

E por que considero isso um problema?

A resposta é simples: se você introduzir novas colunas ou modificar as colunas da base a ser pesquisada, terá que pesquisar todas as células que contém fórmulas com PROCV e alterá-las manualmente…

Isso gera um grande risco de termos fórmulas inconsistentes na nossa planilha, gerando mensagens de erro, ou, o que é pior, trazendo valores numéricos equivocados.

Podemos contornar o problema gerado pela constante numérica ao substituirmos esse valor pela fórmula CORRESP.

Vejamos um exemplo:

Na imagem a seguir temos um sistema simples de informações para geração de um gráfico.

0215_01

As informações são obtidas a partir de pesquisa dos valores na tabela de valores por região e por mês.

Temos os seguintes intervalos nomeados:

tblfonteInformacoes [B2:G6]
rngRegioes [A2:A6]
rngMeses [A1:G1]

Se fôssemos utilizar a abordagem normal do PROCV colocaríamos em B16 a fórmula
=PROCV($A$16;tblFonteInformacoes;2;FALSO)

Aí surge outro inconveniente de utilizarmos constantes numéricas para as colunas: se copiarmos a fórmula para outra célula, temos que realizar o ajuste da referência à coluna manualmente.

Ao invés disso, utilizaremos a seguinte fórmula em B6:
=PROCV($A$16;tblFonteInformacoes;CORRESP(B$15;rngMeses;0);FALSO)

Observem que a função CORRESP busca a correspondência de valores entre o cabeçalho da tabela de montagem do gráfico e a tabela que contém as informações gerais.

Agora fica fácil copiar a fórmula de B6 para o resto das células do intervalo B6:G6, pois os cabeçalhos serão adequadamente pesquisados.

As colunas de quaisquer das tabelas podem ser reposicionadas à vontade e as duas podem possuir ordens diferentes.

Lembre-se dessa dica na próxima vez que utilizar um PROCV.

O arquivo está disponível para Download

[ ]s

Anúncios

In Excel We Trust

Marcado com: , , , , , , ,
Publicado em Nível: Intermediário

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: