0205-Eliminando colunas auxiliares

Normalmente utilizamos colunas auxiliares quando nos deparamos com problemas que exigem alguma modificação nos dados.

Exemplos:

  1. Temos datas expressas como dia/mês/ano e queremos saber o dia da semana em que ocorreram.
  2. Precisamos obter uma soma que envolve operações entre duas colunas, como a soma da diferença dos quadrados dos valores das colunas A e B.
  3. Queremos pesquisar em uma outra tabela apenas os 4 primeiros caracteres da coluna A.

A questão é que embora seja o procedimento mais intuitivo, quase nunca precisamos verdadeiramente dessas coluna adicionais.

Vamos analisar os 4 exemplos acima utilizando colunas auxiliares e, em paralelo, a solução na qual elas são dispensadas.

1. Mostrar o dia da semana.

Nesse caso, basta modificar o formato com que as datas são exibidas.

Se tivermos numa célula, por exemplo, o valor 30/08/2013, basta definir o formato para ddd dd/mm/aa que o dia da semana será apresentado à frente da data. Ficaríamos com sex 30/08/2013.

2. Realizar operações envolvendo colunas.

Quando queremos obter uma operação como a diferença de quadrados dos valores de duas colunas, diagamos A e B, o usual é criarmos uma terceira coluna, realizar nela a diferença dos quadrados (A² – B²) e depois obtemos o resultado dos elementos desta terceira coluna.

Mas podemos fazer numa única fórmula. Se os dados estiverem no intervalo A2:B10, podemos usar uma fórmula como =SOMARPRODUTO(A2:A10^2-B2:B10^2) para obter o mesmo resultado sem a necessidade de uma coluna adicional.

3. Pesquisar parte de uma cadeia de texto.

Pense que precisa retornar, através de um PROCV um resultado de uma tabela. Mas a sua pesquisa só pode levar em consideração os 4 primeiros caracteres dos valores da coluna A.

De imediato vem à mente, colocar numa outra coluna uma fórmula como =ESQUERDA(A1;4) e pesquisar os valores a partir desta coluna.

Mas podemos simplificar: =PROCV(ESQUERDA(A1;4)….) retorna o mesmo valor.

Esse são apenas 3 exemplos, mas vocês podem ser lembrar de muitos outros com os quais se depararam.

Vocês devem estar se perguntando: Mas qual o problema? O resultado obtido não é o mesmo?

Numa planilha que montei para testes com 3,39 MB, cada coluna adicional representava um incremento de 0,12 MB e um incremento de 0,03 seg no tempo de cálculo se esta coluna tivesse uma fórmula simples.

Fórmulas mais complexas comprometem ainda mais a performance da planilha.

Em outras palavras, quando mais pudermos aliviar o volume de informações e cálculos de uma planilha, mais leve ela se torna, mas rápidos os cálculos são processados e reduzirmos os riscos de perda de informações por dados corrompidos.

Sempre que pensarem em inserir uma coluna adicional, reflitam se ela é mesmo necessária, ou se a mesma funcionalidade pode ser atingida através de fórmulas mais elaboradas, ou como vimos acima, pequenas mudanças na formatação.

Muitas vezes iniciamos um projeto, criando essas colunas para dividirmos e auditarmos os resultados dos passos intermediários de uma fórmula complexa. Se isso for feito, lembrem-se de retirar as colunas desnecessárias quando concluir que os resultado são confiáveis.

Se há duas ou mais alternativas para obter-se um resultado, busque sempre aquela que consome menos recursos do sistema.

Anúncios

In Excel We Trust

Marcado com: , , , ,
Publicado em Nível: Intermediário

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 2,077,129

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.537 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: