Desafio 0005

E vamos à resposta do último desafio:

E para esta semana o desafio é:

Como obter o resultado da soma dos números das placas listadas abaixo?:

Ou seja: 0001+2452+…+7178 = ?

E antes que me esqueça: Não vale usar colunas auxiliares!

Abraços e boa sorte no desafio.

Anúncios

In Excel We Trust

Marcado com:
Publicado em Desafio
7 comentários em “Desafio 0005
  1. Lucca disse:

    Sendo A1 a célula de referência:
    SUM(MID(MID(A1;MATCH(0;(ISERROR(MID(A1;ROW(INDIRECT(“1:”&LEN(A1)));1)*1)*1);0);LEN(A1)-SUM((ISERROR((MID(A1;ROW((INDIRECT(“1:”&LEN(A1))));1)*1)*1))));ROW(INDIRECT(“1:”&LEN(MID(A1;MATCH(0;(ISERROR(MID(A1;ROW(INDIRECT(“1:”&LEN(A1)));1)*1)*1);0);LEN(A1)-SUM((ISERROR((MID(A1;ROW((INDIRECT(“1:”&LEN(A1))));1)*1)*1)))))));1)*1)

    • Obrigado pela contribuição, Lucca.
      Mas observe que a sua fórmula retorna a soma dos dígitos de uma placa.
      Por exemplo, para WST-2452, traz 2+4+5+2, o que é diferente da proposta do desafio.
      Há uma versão mais simples da fórmula que você postou e que não é matricial:
      =SUMPRODUCT(1*MID(A1,ROW(A5:A8),1))
      Continue participando e mais sorte na próxima.

      [ ]s

  2. Neto disse:

    =SOMA(–DIREITA(A1;4);–DIREITA(A2;4);–DIREITA(A3;4);–DIREITA(A4;4);–DIREITA(A5;4);–DIREITA(A6;4);–DIREITA(A7;4);–DIREITA(A8;4);–DIREITA(A9;4);–DIREITA(A10;4))

    • Boa noite, Neto.
      Não sei se foi algum problema na hora de digitar os valores, mas se aplicar a fórmula da maneira que está será obtido um valor negativo.
      Precisaria multiplicar a soma por -1 para corrigir isso.
      Que tal tentar simplificar a fórmula?
      [ ]s

  3. Lucca disse:

    Juntando as duas respostas… =SUMPRODUCT(-1*RIGHT(A1:A10;5)).
    Muito bom! abs

    • Me permita duas correções:
      Multiplique por 1 e não por -1.
      (Se o produto for por -1, todos os números obtidos serão negativos…)
      São 4 caracteres à direita.
      Fazendo esses ajustes, temos:
      =SUMPRODUCT(1*RIGHT(A1:A10;4))
      Parabéns!
      [ ]s

  4. Maycon disse:

    Não dá pra ver as imagens

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 2,077,129

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.537 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: