0175-Função SEERRO

Vamos partir de um exemplo simples: uma fórmula para calcular o quociente entre duas outras células.

Poder ser algo como =A1/A2.

Não é possível apresentar o resultado desta fórmula se A2 estiver vazia, ou ser for inserido o valor 0 (zero).

Neste caso, o Excel exibe a mensagem de erro: #DIV/0!.

Podemos evitar que isto ocorra, mudando a fórmula para que exiba uma mensagem ou valor diferente.

Até a versão 2007 isso só era possível utilizando a função SE.

Uma das formulações possíveis é: =SE(A2<>0;”-“;A1/A2).

A partir da versão 2007 foi introduzida uma nova função chamada SEERRO.

Ela simplifica a formulação, podendo escrever fórmulas como: =SEERRO(A1/A2;”-“).

O primeiro argumento é a fórmula que queremos calcular e o segundo é o valor alternativo a ser exibido se a fórmula resultar em erro.

A fórmula a ser calculada pode ser simples como o nosso exemplo, ou bem mais complexa, você poderá usar SEERRO com a mesma facilidade.

Se você trabalha com as versões mais recentes do Excel, tente utilizar esta função para simplificar suas fórmulas.

 

Anúncios

In Excel We Trust

Marcado com: , , , , ,
Publicado em Nível: Intermediário

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 2,077,129

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.537 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: