0141-Encadeando múltiplos SEs

Já vimos no tópico 0002 que é possível utilizar a função PROCV para criar opções para condições múltiplas.

Há, usuários no entanto, que preferem trabalhar com vários SEs encadeados. Além de mais trabalhosa esta opção está limitada ao número de funções aninhadas de cada versão do Excel.

Para evitar este aninhamento é possível encadear as funções SE com base no tipo de retorno esperado.

1. Se os retornos forem não numéricos: utilizar o símbolo de concatenação ( &) para encadear as funções.

Ex1 =SE(A1>0;”POSITIVO”;””)&SE(A1<0;"NEGATIVO";"")&SE(A1=0;"NULO";"").

Neste exemplo será exibida uma mansagem conforme o valor seja positivo, negativo ou nulo.

Para cada um dos SEs devemos estabelecer o resultado esperado caso a condição seja verdadeira e definir uma cadeia vazia (“”) caso seja falsa.

2. Se os retornos forem numéricos: utilizar o símbolo de soma(+) para encadear as funções.

Ex. =SE(A1>0;5)+SE(A1<0;-5)+SE(A1=0;1).

Neste caso, será atribuído um número com base no valor de A1.

Para cada um dos SEs devemos definir apenas o resultado da condição verdadeira. Quando esta condição não é atendida o resultado é FALSO. Como nas operações de soma o valor FALSO é considerado como 0(zero) apenas a condição que for satisfeita irá contribuir para o resultado final.

Embora tenhamos em ambos os exemplos encadeado três funções SE, este encadeamento pode estender-se até o limite suportado para a entrada de fórmulas da versão em uso do Excel. Cada um dos SEs pode utilizar testes lógicos como E e OU para aumentar a complexidade de acordo com as demandas do usuário.

Anúncios

In Excel We Trust

Marcado com: , , , , ,
Publicado em Nível: Intermediário
3 comentários em “0141-Encadeando múltiplos SEs
  1. Edson Zita disse:

    Ajuda-me, gostaria de fazer uma formula no excel com condições multiplas onde uma delas seja para uma condição não esperada, na qual o valor deve ser zero

  2. Elton disse:

    Boa tarde,

    Alguém poderia por favor me ajudar com essa formula?

    Se A1 é Igual a “maria” e A2 é igual a “joão” Resultado é 500 / Mas se A1 é igual a Pedro e A2 igual a João Resultado é 100.

    Grato,

    • Robson Fortes disse:

      Boa tarde Elton, não sei se tem uma forma mais simples, mas esta aqui funcionou:

      =SE(A1=”maria”;SE(A2=”joão”;500);SE(A1=”pedro”;SE(A2=”joão”;100)))

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: