0137-Como tirar proveito de valores de erros na construção de gráficos

Em diversos posts, mostramos como evitar a geração de erros em fórmula. Mas há, ao menos, uma situação em que podemos nos beneficiar da geração de um erro.

Tomemos o exemplo a seguir:

Nesta imagem da planilha, podemos observar uma pequena “base de dados” que representa as vendas por mês em três diferentes regiões geográficas. Para construção de um gráfico que permita a visualização do comportamento destas vendas, foi criada uma tabela resumo que consolida as informações por mês utilizando a função SOMASE. Para os meses em que não há valores, digitados o resultado da fórmula é zero, o causa uma distorção no gráfico. Da forma que ficou, temos a impressão que houve zero de vendas, quando na realidade estes são períodos ainda a serem consolidados.

Agora vamos substituir, a partir de G3, a fórmula

=SOMASE($A$2:$A$37;F3;$C$2:$C$37)

Por:

=SE(SOMASE($A$2:$A$37;F3;$C$2:$C$37)=0;NÃO.DISP();SOMASE($A$2:$A$37;F3;$C$2:$C$37))

Desta forma, ao invés do valor zero para a soma, aparecerá o erro #N/D.

Vejamos como fica a planilha:

Observe que o gráfico não apresenta mais os valores zero para os meses posteriores a junho, deixando claro que há valores a serem informados.

Embora resolva o problema do gráfico, concordo que não é a melhor solução estética deixar estes #N/D na tabela.

O truque para resolver este impasse é apelar para a formatação condicional. Selecionando o intervalo G3:G14 e selecionando a formatação condicional, vamos definir como regra o resultado de uma fórmula:

Desta forma, a formatação condicional irá ocorrer sempre que no intervalo selecionado houve um valor de erro (=ÉERROS(G3)). Clicando em Formatar.., vamos definir que a fonte deverá ser Branca, pressionando Ok até retornar para a planilha.

Vejamos o resultado:

Acesse aqui o arquivo de exemplo: Gráfico x Erros

In Excel We Trust

Marcado com: , , , , , ,
Publicado em Nível: Intermediário

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 1,964,110

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.476 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: