0118-Referências absolutas e relativas em fórmulas

Quando observamos as fórmulas criadas no Excel, podemos notar que algumas vezes os endereços de células aparecem na forma direta de suas coordenadas coluna x linha (Ex. =SOMA(A1:A10)) e em outras vezes cifrões aparecem misturados a esta notação (Ex. =SOMA($A$1:$A$10). O que isto significa?
O primeiro tipo de notação é denominado de referência relativa e o segundo de referência absoluta.
Os resultados calculados de ambas as formas são iguais, o que nos leva à pergunta seguinte: “então por que existe esta diferenciação?”.
Fica mais fácil entender a questão exemplificando.


Observe que inserimos a primeira versão da fórmula na célula B1.
O que acontece agora se copiarmos o conteúdo da célula B1 para a célula B2?

Observe agora que em B2 temos =SOMA(A2:A11).
Isto ocorre por que o intervalo utilizado é uma referência relativa à posição da célula na qual foi inserida a fórmula. A interpretação do Excel de uma fórmula como esta é: “Somar o intervalo de células cujo canto superior esquerdo se localiza na célula imediatamente à esquerda, possui dez linhas e uma coluna”. Desta forma quando copiamos a fórmula de B1 para B2, alteramos a referência e a fórmula é ajustada de acordo com este novo referencial.
Vamos agora repetir a simulação digitando em B1 a segunda versão da fórmula.


Agora copiaremos a célula B1 definindo B2 como destino.

Podemos agora observar quem em B2 temos =SOMA($A$1:$A$10) que é exatamente a mesma fórmula digitada em B1.
Como foram utilizadas referências absolutas, independentemente do local para o qual a fórmula seja copiada a interpretação será : “Somar as células do intervalo A1:A10”.
Quer dizer que a preocupação de definir o tipo de referência só é importante quando a fórmula for copiada de um para outro local na planilha?
Isso mesmo. Porém a frequência com que esta cópia ocorre é muito grande. Eu diria que é muito difícil desenvolver um projeto de planilha que em as fórmulas não sejam repetidas em várias células diferentes.
Vamos a um exemplo de erro comum:
Observe que a fórmula inserida em …. utiliza referência relativa para o intervalo de pesquisa da função PROCV.

Vejamos o que acontece quando a fórmula é copiada para as células imediatamente abaixo.


Já vi usuários perderem muito tempo reclamando que o Excel “está errando numa fórmula simples” por desconhecimento da aplicação do conceito de referências absolutas.
Eis a forma correta:


Vale a pena ressaltar que uma referência pode ser relativa ou absoluta em relação às linhas, às colunas ou a ambas.
Exemplos:

  • $A$1: Referência absoluta em relação a linhas e colunas;
  • $A1: Referência absoluta em relação às colunas e relativa em relação às linhas;
  • A$1: Referência absoluta em relação às linhas e relativa em relação às colunas;
  • A1: Referência relativa em relação a linhas e colunas.

No exemplo a seguir, faremos uso das diferentes referências, utilizando a função VF para construir a tabela que correlaciona o saldo de aplicações realizadas com diferentes combinações de taxas e períodos de aplicações, a partir de um investimento inicial:

Observem que a taxa, que é referenciada na coluna A, é pesquisada através de uma referência absoluta em relação à coluna ($A4), o número de períodos de capitalização são pesquisados na linha 3, por isto foi utilizada uma referência absoluta em relação à linha (B$3) e finalmente o valor a ser investido é fixo, de forma que utilizamos referências absolutas para linha e coluna ($A$1).

Desta forma ao copiarmos a fórmula para as demais células da nossa tabela, obteremos o resultado desejado:

A regra é sempre colocar como referência absoluta a parte do endereço, linha ou coluna, que deve permanecer fixa quando a fórmula for copiada.

In Excel We Trust

Marcado com: , , , , , ,
Publicado em Nível: Básico

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 1,964,110

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.476 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: