0083-Retornar uma fórmula como texto

Em vários dos nossos posts exibimos conjuntamente fórmulas e os valores retornados por ela.
Se tiver necessidade de criar uma estrutura similar em seus arquivos para facilitar sua vida e de outros usuários, utilize uma função como esta aqui:

Function INFO_FORMULA(rg As Range)
INFO_FORMULA = rg.FormulaLocal
End Function

O argumento da função é uma célula e ela retorna a fórmula inserida na referência como uma cadeia de texto.

Exemplo: Se em A1 você tiver a fórmula =SOMA(B2:B5), poderá enxergá-la digitando em outra célula a fórmula =INFO_FORMULA(A1).

In Excel We Trust

Marcado com: , , , , ,
Publicado em Nível: Avançado

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 1,969,548

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.477 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: