0082-Somando células que contém números no formato texto

Alguma vez tentou somar células que contém números e o resultado foi zero?

Provavelmente os “números” eram da verdade cadeias de texto.

Se você quiser somar os valores do intervalo A1:A10 e estes são “números” como “12”, “20”, etc. não se aperte. Utilize a fórmula =SOMARPRODUTO(1*(A1:A10)).

Por que isto funciona?

Por que ao multiplicar um valor de texto por 1 você obrigado o Excel a enxergá-lo como número.

In Excel We Trust

Marcado com: , , , , , ,
Publicado em Nível: Intermediário
4 comentários em “0082-Somando células que contém números no formato texto
  1. flaviox27 disse:

    tá aí. Mais uma simples e muito boa. Tem um relatório que eu rodo que sai assim. Pra somar eu ia em “Substituir” e trocava “0” por “0”, “1” por “1”, etc. Agora ficou fácil. Valeu !

  2. Afonso Serri disse:

    Realmente essa é uma dica muito boa. Trabalho com o SAP e ao extrair alguma base da dados para excel, algumas colunas costumam ser exportadas como texto. Já quebrei muito a cabeça tentando enteder o motivo de alguma fórmula não estar funcionando ! Dependendo do cenário fica complicado identificar que as células da coluna “X” estão no formato texto.

    Uso muito essa forma de transformar texto em número. Uso também a fúnção “Valor” para resolver esse “problema”. Por exemplo: =SOMARPRODUTO(VALOR(A1:A10)). Essa se não me engano, foi tu mesmo quem me ajudou no fórum Júlio Battisti. rsrs

    Falando nisso, o que será que aconteceu com o fórum ?

    Abraços.

    • Boa noite, Afonso.

      A última notícia que eu tive dos responsáveis pelo fórum do JB é que houve um ataque de hackers que danificou a estrutura da base de dados com as informações dos fóruns.

      Uma pena a perda de tantas dicas sobre o Excel e outros aplicativos.

      Abraços

  3. Obrigado, cara, você fez uma contribuição excelente. Salvou a minha pela hehehehe

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 1,963,899

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.476 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: