0078-Operações com intervalos que contêm valores de erro

Já vimos no post Evitando exibição de erros em fórmulas como evitar que as nossas fórmulas retornem valores de erro.

Algumas vezes não somos nós que montamos as fórmulas e não temos permissão e às vezes conhecimento para alterá-las. Há alguns casos em que as fórmulas são tão grandes que simplesmente não há espaço para inserir alternativas para o tratamento de erro.

Mas aí como fazer para, por exemplo, somar uma série de valores se dentre eles houver um #N/D e não pudermos alterar as fórmulas? Alguns, como eu mesmo já tive que fazer, copiam este intervalo e colam-no como valores em outra planilha, eliminam o(s) valor(es) de erro e podem efetuar seus cálculos.

A abordagem acima dá certo, mas com certeza também dá um trabalho danado…

Então vamos montar uma outra abordagem utilizando fórmulas matriciais.

Partindo do intervalo de dados a seguir vamos mostrar como é possível realizar os cálculos.

A
1 Valores
2 25
3 32
4 31
5 #N/D
6 28
7 33

Alternativa 1:
=SOMA(SE(ÉNÚM($A$2:$A$7);$A$2:$A$7))

Alternativa2:
=SOMA(SE(ÉERROS($A$2:$A$7);””;$A$2:$A$7))

Alternativa3:
=SOMA(SEERRO($A$2:$A$7;””))

As 3 fórmulas matriciais acima retornam o valor 149 para a soma das células do intervalo A2:A7, desprezando-se o valor de erro.
Embora utilizem enfoques diferentes, as três alternativas valem-se do princípio de excluir da operação os valores não numéricos.
Caso queiramos utilizar outra forma para resumir os dados, basta substituir SOMA por MÉDIA, MÁXIMO, ou outra função de interesse.

In Excel We Trust

Marcado com: , , , , , , ,
Publicado em Nível: Intermediário
2 comentários em “0078-Operações com intervalos que contêm valores de erro
  1. mais fácil.. =SOMASE(A2:A7;”>0″;A2:A7)

  2. Lucas Negreiros disse:

    Show de bola, fórmula bem simples e muito eficiente, obrigado, me ajudou bastante.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 1,963,899

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.476 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: