0078-Operações com intervalos que contêm valores de erro

Já vimos no post Evitando exibição de erros em fórmulas como evitar que as nossas fórmulas retornem valores de erro.

Algumas vezes não somos nós que montamos as fórmulas e não temos permissão e às vezes conhecimento para alterá-las. Há alguns casos em que as fórmulas são tão grandes que simplesmente não há espaço para inserir alternativas para o tratamento de erro.

Mas aí como fazer para, por exemplo, somar uma série de valores se dentre eles houver um #N/D e não pudermos alterar as fórmulas? Alguns, como eu mesmo já tive que fazer, copiam este intervalo e colam-no como valores em outra planilha, eliminam o(s) valor(es) de erro e podem efetuar seus cálculos.

A abordagem acima dá certo, mas com certeza também dá um trabalho danado…

Então vamos montar uma outra abordagem utilizando fórmulas matriciais.

Partindo do intervalo de dados a seguir vamos mostrar como é possível realizar os cálculos.

A
1 Valores
2 25
3 32
4 31
5 #N/D
6 28
7 33

Alternativa 1:
=SOMA(SE(ÉNÚM($A$2:$A$7);$A$2:$A$7))

Alternativa2:
=SOMA(SE(ÉERROS($A$2:$A$7);””;$A$2:$A$7))

Alternativa3:
=SOMA(SEERRO($A$2:$A$7;””))

As 3 fórmulas matriciais acima retornam o valor 149 para a soma das células do intervalo A2:A7, desprezando-se o valor de erro.
Embora utilizem enfoques diferentes, as três alternativas valem-se do princípio de excluir da operação os valores não numéricos.
Caso queiramos utilizar outra forma para resumir os dados, basta substituir SOMA por MÉDIA, MÁXIMO, ou outra função de interesse.

Anúncios

In Excel We Trust

Marcado com: , , , , , , ,
Publicado em Nível: Intermediário
6 comentários em “0078-Operações com intervalos que contêm valores de erro
  1. mais fácil.. =SOMASE(A2:A7;”>0″;A2:A7)

  2. Lucas Negreiros disse:

    Show de bola, fórmula bem simples e muito eficiente, obrigado, me ajudou bastante.

  3. Roberto costa disse:

    Muito obrigado.

    Depois de longas 5 horas pesquisando, você foi luz.

    Deus te abençoe

  4. Ibson Tadeu disse:

    Tenho uma dúvida:

    Preciso fazer uma consulta entre matrizes e descobrir quantos numeros uma tem em comum com a outra, tipo: A= 1 2 3 4 5 6 7 8 e B= 3, 7,8, 10, 11, 31; que pudesse tão somente contar os números e me retornar “3”, eu já consegui antes mas a formula ficou com absurdos 800 caracteres/célula há algum jeito mais fácil?

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: