0076-Contabilizando o sábado como dia útil

A função DIATRABALHOTOTAL retorna o número de dias úteis entre duas datas.

Isto obviamente exclui da contagem os sábados.

Mas e se quisermos saber quantos “dias úteis” incluindo os sábados há entre duas datas?

Colocando a data inicial em A1 e a final em A2, podemos utilizar a fórmula

=SOMARPRODUTO(N(DIA.DA.SEMANA(LIN(INDIRETO(A1&”:”&A2)))1))

A fórmula contabiliza todos os dias do período considerado que não ocorrem num domingo, mas não leva em consideração a presença de outros feriados entre as datas fornecidas.

Para corrigir esta distorção vamos subtrair do valor acima, a quantidade de feriados que não ocorreram num sábado. Para isso é necessário fornecer uma lista de feriados da mesma forma que na função DIATRABALHOTOTAL. Vamos supor que esta lista tenha sido inserida no intervalo G1:G20.

=SOMARPRODUTO(N(DIA.DA.SEMANA(LIN(INDIRETO(A1&”:”&A2)))1))-
SOMARPRODUTO(N(DIA.DA.SEMANA(($G$1:$G$20=$A$1)*($G$1:$G$20))7))

Anúncios

In Excel We Trust

Marcado com: , , , , , , , ,
Publicado em Nível: Avançado
4 comentários em “0076-Contabilizando o sábado como dia útil
  1. José Paulino dos Santos disse:

    Boa noite, show de bola a dica. Mas tenha uma pergunta e qnd o feriado cair no sábado? Fiz uma planilha mas me deparei com este problema.

  2. Philipi disse:

    Não consegui com essa fórmula, mas através dela cheguei ao resultado correto:

    =SOMA(SE(DIA.DA.SEMANA(LIN(INDIRETO(A1&”:”&A2)))=1;1);0)

  3. Philipi disse:

    Não consegui com essa fórmula, mas através dela cheguei ao resultado correto.

    A fórmula abaixo retorna os dias úteis somado com os sábados do período (fórmula matricial)

    {=SOMA((DIATRABALHOTOTAL(A1;A2));SE(DIA.DA.SEMANA(LIN(INDIRETO(A1&”:”&A2)))=1;1))}

  4. boa noite, se possivel tire me duvida,

    03/09/2016

    estou usando a função dia trabalho e está funcionando perfeitamente, porém neste mês de setembro trabalhamos um sábado(especificamente dia 03) e este sábado teria que aparecer como dia utel tem como me ajuda a modifica a formula.

    desde já agradeço.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 2,069,536

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.534 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: