0072-Calculando número de ocorrências de um dia da semana

Deseja saber quantos sábados ocorreram entre duas datas no Excel?

Digite em A1 a data inicial.

Digite em A2 a data final

Utilize esta fórmula aqui para contar o número de sábados:

=SOMARPRODUTO(N(DIA.DA.SEMANA(LIN(INDIRETO(A1&”:”&A2)))=7))

Se quiser calcular a quantidade de outros dias da semana substitua o valor 7 pelo valor correspondente ao dia da semana (Dom=1, Seg=2;….;Sab=7).

Como esta fórmula funciona.

Tudo começa com este pedaço aqui: A1&”:”&A2. Se, por exemplo, A1: 01/11/2011 e A2: 26/05/2011, a fórmula retorna: “40544:40609″. Estes números correspondem aos números de séries de cada uma dessas datas.

Em seguida, INDIRETO(A1&”:”&A2) retorna o intervalo de linhas 40544:40609

LIN( INDIRETO(A1&”:”&A2)) retorna a série de valores 40544;40545;40546;….;40609. Ou seja, o número serial de cada um dos dias entre as datas fornecidas.

A fórmula DIA.DA.SEMANA(LIN( INDIRETO(A1&”:”&A2))) retornará os dias da semana correspondentes à série das datas. Como 01/01/2011 foi um sábado e 26/05/2011 uma quinta-feira, teremos como resultado {7;1;2;3;…..;5}

Quando comparamos DIA.DA.SEMANA(LIN( INDIRETO(A1&”:”&A2)))=7, obtemos uma matriz de valores Booleanos: {VERDADEIRO;FALSO;FALSO;FALSO;…..;FALSO}

Como o nosso objetivo é contar o número de valores VERDADEIRO, utilizamos a função N que transforma VERDADEIRO em 1(um) e FALSO em 0(zero). N(DIA.DA.SEMANA(LIN( INDIRETO(A1&”:”&A2)))=7)) = {1;0;0;0;…;0}

Finalmente aplicamos a função SOMARPRODUTO ao resultado acima para que sejam contados todos os valores 1.

No exemplo de datas que sugerimos, o resultado obtido é 21.

In Excel We Trust

Marcado com: , , , , , , , ,
Publicado em Nível: Intermediário
2 comentários em “0072-Calculando número de ocorrências de um dia da semana
  1. flaviox27 disse:

    Esta fórmula é muito importante para várias aplicações. Bem explicada. Obrigado.

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 1,963,899

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.476 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: