0062-Determinando o endereço de uma célula que satisfaça uma condição

Se tivermos um determinado intervalo de células, é fácil determinar, por exemplo, qual o maior valor utilizando a função máximo.

Mas se quisermos saber, qual o endereço da célula que contém o valor máximo, como obtê-lo?

A solução é utilizar a função SOMARPRODUTO em conjunto com a função ENDEREÇO.

Utilizaremos a primeira para determinar a linha e a coluna em que ocorrem o valor máximo e a segunda será utilizada para combinar estas informações para determinar a posição da célula.

Vamos por partes:

Determinando a linha: =SOMARPRODUTO(LIN($A$1:$E$9)*($A$1:$E$9=MÁXIMO($A$1:$E$9)))

Determinando a coluna: SOMARPRODUTO(COL($A$1:$E$9)*($A$1:$E$9=MÁXIMO($A$1:$E$9)))

Retornando o endereço: =ENDEREÇO(SOMARPRODUTO(LIN($A$1:$E$9)*($A$1:$E$9=MÁXIMO($A$1:$E$9)));SOMARPRODUTO(COL($A$1:$E$9)*($A$1:$E$9=MÁXIMO($A$1:$E$9))))

Veja no exemplo, que inclui a localização do valor mínimo: Determinando o endereço

OBS: Esta fórmula só é válida se houver apenas uma ocorrência do valor máximo ou qualquer outro valor pesquisado.

Anúncios

In Excel We Trust

Marcado com: , , , , ,
Publicado em Nível: Intermediário

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: