0061-Função SE

Na minha opinião uma das funções mais simples e úteis do Excel.

Sua sintaxe é SE(teste_lógico; valor_se_verdadeiro;valor_se_falso)

  • teste_lógico: resultante de uma comparação, resulta em VERDADEIRO ou FALSO;

  • valor_se_verdadeiro: valor assumido pela função, caso teste_lógico seja VERDADEIRO;

  • valor_se_falso: valor assumido pela função, caso teste_lógico seja FALSO.

Antes de realizarmos alguns exemplos de utilização, vamos analisar duas outras funções do grupo de funções lógicas.

OU(lógico1; lógico2;….,lógicoN)

  • lógico: comparações que retornam o resultado VERDADEIRO ou FALSO

  • OU será VERDADEIRO se, pelo menos um dos valores lógicos for VERDADEIRO

  • Podem ser utilizados até 255 argumentos (N ≤ 255)

E(lógico1; lógico2;….,lógicoN)

  • lógico: comparações que retornam o resultado VERDADEIRO ou FALSO

  • E será VERDADEIRO se todos os valores lógicos tiverem o valor VERDADEIRO

  • Podem ser utilizados até 255 argumentos (N ≤ 255)

Essas duas funções são muito utilizadas em conjunto com a função SE para avaliar condições mais complexas.

Exemplos de uso:

Ex1. Se o valor digitado em A1 for maior do zero, exibir a mensagem “positivo”, caso contrário exibir “negativo”.

Solução =SE(A1>0;”positivo”;”negativo”)

Ex2. Se o valor digitado em A1 for maior do zero, exibir a mensagem “positivo”, se for zero, exibir a mensagem “nulo” e caso contrário exibir “negativo”.

Solução: =SE(A1>0;”positivo”;SE(A1=0;”nulo”;”negativo”))
Comentário: Observe que para resolver este segundo exemplo, utilizamos duas vezes a função SE. Utilizar uma função como argumento para uma outra é o que chamamos de “aninhar” funções. No caso da função SE, pode haver até 64 aninhamentos.

Ex3. Se o valor digitado em A1 estiver entre 1 e 10, exibir a mensagem “dentro do intervalo”, caso contrário, exibir “fora do intervalo”.

Solução1: =SE(E(A1>1;A1<10);"dentro do intervalo";"fora do intervalo")
Comentário: Para que um número esteja situado dentro do intervalo ele deve ser simultaneamente, maior do que um e menor do que 10. Como ambas as condições tem que ser atendidas, devemos utilizar a função E.

Solução2: =SE(OU(A1=10);"fora do intervalo";"dentro do intervalo")
Comentário: Esta também é uma solução válida que parte do raciocínio oposto: para que o número esteja fora do intervalo ele deve ser menor ou igual a um OU deve ser maior ou igual a 10.

Ex4. Se o valor digitado em A1 for maior do que o valor digitado em A2, exibir a mensagem “A1 é maior do que A2”, caso contrário a célula deve ficar em branco.

Solução: =SE(A1>A2;”A1 é maior do que A2″;””)
Comentário: Coloquei este exemplo, para mostrar que o uso de aspas simultâneas gera uma cadeia de texto vazia como valor da célula.

Ex5: Se o valor digitado em A1 for menor ou igual a 5, exibir a mensagem “o aluno foi reprovado com nota ” seguida do valor de A1, se a nota for maior do que 5 exibir a mensagem “o aluno foi aprovado com nota ” seguida do valor de A1.

Solução1: =SE(A1<=5;"o aluno foi reprovado com nota "&A1;"o aluno foi aprovado com nota "&A1)

Solução2: ="o aluno foi "&SE(A1<=5;"reprovado";"aprovado")&" com nota "&A1
Comentários: À medida que aumenta a complexidade, aumenta também o número de soluções possíveis para um problema. Embora seja menos usual, a Solução2 é mais sintética e elegante.

Este tópico, foi uma breve introdução para que no futuro estejamos acostumados a trabalhar na solução de problemas mais complexos, envolvendo o uso de condicionais.

In Excel We Trust

Marcado com: , , , ,
Publicado em Nível: Básico
59 comentários em “0061-Função SE
  1. Claudi disse:

    obrigado !!

  2. Estou trabalhando com uma planilha Ata Escolar, nessa planilha há 09 (nove) disciplinas, cada uma recebe uma nota (média final), mas não tenho uma formula que abrange todas
    notas para obter um resultado. O resultado que quero é: Aprovado, Reprovado, Evadido, transferido.
    A fórmula desejada:
    =SE(M17:U17>=5;”-“;”Ap.”;”Rep.”;”Ev.;”Tr.” )

  3. Paulo S. Possato disse:

    Aprendi mais uma!
    Obrigado!

  4. Ana Paula disse:

    OLÁ! COMO PODERÍAMOS TROCAR UMA IDEIA PARA QUE VOCÊ ME AJUDASSE A RESOLVER UM PROBLEMA COM A FUNÇÃO SE COMPOSTA?

  5. Danilo disse:

    Boa tarde! E se ao inves de ser numeros, for horas? Tenho uma celula com um horario, em outra celula preciso colocar um X se ela estiver entre as 21H e 04h, pode me ajudar?

  6. Boa tarde! muito boa a explicação.
    Gostaria de fazer o seguinte: em uma coluna eu tenho a validação de dados aprovado/ reprovado e aguardando, gostaria de fazer OUTRA coluna que automaticamente quando eu colocasse na CÉLULA com validação de dados APROVADO, a outra célula na outra coluna surgiria um status CONCLUÍDO.

  7. Rafael disse:

    Pessoal, podem me ajudar ?

    Eu tenho uma planilha que quero trazer a informação da seguinte forma:

    Por exemplo:

    A1 B1
    Google 10%
    Yahoo 5%
    Bing 20%
    Terra 50%

    Quero fazer uma pesquisa na coluna B1 e se encontrar um percentual maior que 30% ele me traga a informação da celula A1.

    Neste caso eu teria a informação “terra”

    Podem me ajudar ??

  8. Eduardo disse:

    Boa tarde!
    tenho uma planilha que puxa automaticamente a subtração de outras colunas. Mas nesta coluna que que apareça somente numeros negativos como faço.

  9. Heloisa disse:

    BOM DIA. SERÁ QUE ALGUÉM PODERIA ME AJUDAR? TENHO 171 PLANILHAS IGUALMENTE FORMULADAS, SÓ MUDAM OS VALORES DE ENTRADA DIGITADOS. TODAS ESTÃO PERFEITAS. POR QUE UMA ÚNICA CÉLULA, EM UMA DESTAS PLANILHAS, ESTÁ RETORNANDO MOEDA -0,00 (ZERO COMO NÚMERO NEGATIVO)? OBRIGADA.

  10. Eródoto disse:

    Boa noite!
    Tenho uma fórmula simples de subtração. Gostaria de colocar junto um comando SE, para que a célula fique em branco, caso o resultado for negativo… como montar a fórmula? Alguem poderia me auxiliar, por fineza?

  11. Gisele disse:

    Bom dia! Tenho que calcular horas a compensar, porém está dando erro. Preciso que se as horas trabalhadas – a carga horária for menor que 15 minutos, me traga o resultado da subtração, senão, 00:00. Fiz assim: =SE(N4-F4<-00:15:00;N4-F4;00:00:00). Obs.: o Excel está configurado para horas negativas e a mensagem é de "erro na fórmula".

  12. Boa noite,
    Quando trabalhar com unidades de tempo, não poderá digitá-las diretamente nas fórmulas.
    Experimente desta forma: =SE(N4-F4<-VALOR.TEMPO("00:15:00");N4-F4;0)
    [ ]s

  13. Alexandre disse:

    Olá!
    Tenho uma planilha que utiliza PROCV, mas quando não encontra o valor, ela retorna: #N/A e por uma questão de apresentação, tentei usar a função SE para que quando não encontre, retorne em branco. Mas esta retornando erro, segue formulá digitada: =IF(VLOOKUP(A:A;’Bco Dados’!$1:$1048576;2;FALSE); VLOOKUP(A:A;’Bco Dados’!$1:$1048576;2;FALSE);””)
    [ ]s

  14. Oi galera preciso de uma função simples mas não consigo se alguém puder ajudar tenho em uma planilha o campo hora chegada e para colocar em outro a seguinte informação se a pessoa chegou entre as 13:00 hs e te 18:59 hs mostre o numero 1 apos as 19:00 mostre o numero 2 se alguem puder ajudar agradeco

  15. Ola, estou precisando fazer um calculo que importa um valor de outra planilha;
    filtrando-o para que nas colunas já dispostas de (POSITIVO,NEGATIVO) o valor seja exibido corretamente respectivamente.
    assim, importa valor, verifica se é maior ou menor que zero, se maior exibe na celular E5 (coluna positiva), se menor E6 (coluna negativa).

    • Bom dia, Ronaldo. Pelo que estendi do teu problema, vc precisará de um SE em cada coluna. Se os valores, por exemplo, estão da coluna C, a coluna positiva é a coluna D e a coluna negativa é a coluna E, vc deve colocar em D1 =SE(C1>0;C1;””) e em E1 =SE(C1<0;C1;""). Abraços!

  16. Gabriela disse:

    preciso que onde tem -R$ 49,48 for negativo o valor seja igual ao de uma outra celula. Ex:
    onde saldo do cartão for negativo preciso que o valor a carregar seja igual ao Valor necessário
    Qtd vale/dia Valor do vale Valor necessário Saldo Cartão Valor a carregar
    2 R$ 4,70 R$ 206,80 -R$ 40,70 247,50

  17. Canelhaz disse:

    Boa noite! No meu caso, encontrei uma solução parcial. Mas há um problema com a fórmula – só consigo fazer com que ela funcione com números positivos. O que pretendia era que a fórmula funcionasse com números negativos. Esta é a fórmula que funciona: =SE(A1<=25;A1;SE(A1750;37,5+(A1-750)))). O que pretendia era -25;-750 ou seja, entre 0 e -25, o valor é A1; entre -25 e -750, o valor será 5% de A1 e e finalmente entre -750 e (-infinito), o valor será 5% de 750, mais a diferença entre 750 e o valor de A1. Será isto possível? Obrigado

  18. Cirço disse:

    Olá! Estou tentando usar a função SE composta com texto e números, porém não está lendo o último processo que seria P7>=5;APROVADO”;”RETIDO”, como proceder?????

    =SE(O7=”AP”;”AP”;SE(O7=”RF”;”RF”;SE(P7>=5;”APROVADO”;”RETIDO”)))

  19. Ricardo Lyone disse:

    Pessoal estou com dificuldade para achar o saldo posterior desta operação. O esperado era um número negativo, mas me retorna um valor positivo. Ajudem por favor.

    Saldo anterior Entradas Saídas Saldo posterior
    -8.587,00 100.000,00 -411.263,00 502.676,00

    • Sua fórmula deverá ser SALDO POSTERIOR = SALDO ANTERIOR + ENTRADAS – SAÍDAS.
      Substitua as variáveis pelas células correspondentes aos valores, por exemplo
      SALDO ANTERIOR: A2
      ENTRADAS: B2
      SAÍDAS: C2
      SALDO POSTERIOR: D2
      D2: =A2 + B2 – C2
      Porém observe que você indicou o saldo anterior e as saídas como números negativos.
      Nesse caso, realize a soma algébrica diretamente D2: =SOMA(A2:C2)

  20. ileusisluna disse:

    Boa tarde!

    Vamos supor que eu tenha a seguinte situação:

    Crédito R$ 500,00
    Débito R$ 600,00

    Então,

    Saldo Credor:

    Se o resultado de (credito – debito) for negativo, informar zero, se positivo, informar o resultado; se for zero, informar zero.

    Saldo Devedor

    Se o resultado de (credito – debito) for negativo, informar o resutlado, se for positivo, informar zero; se for zero, informar zero.

    Como faço isso, por favor?

    Grata desde já.

  21. Andréia disse:

    Olá preciso de um fórmula que calcule entre intervalo de valores e retorne com o texto :
    Exemplo compras acima de R$ 1.000 ganhou 200 pontos .

    Estou perdidinhaaaa …

    Estou tentando a fórmula Se , mas está dando erro.
    ( =SE(G20>=K12<K13;L12;"NÃO GANHOU PONTOS ")

    Compras Acima de
    de R$ 1.000,00 GANHOU 200 Pontos
    de R$ 2.000,00 GANHOU 600 Pontos
    de R$ 3.000,00 GANHOU 1.200 Pontos
    de R$ 4.000,00 GANHOU 2.000 pontos

    Alguém pode me ajudar ?

  22. jeremias disse:

    boa tarde! preciso de ajuda… estou ficando careca de pensar. lá vai:
    tenho dois periodos in1. 09:00 fim1. 10:00 e in2. 17:00 fim2. 18:00. esse é o dado cadastrado.
    quando inserir numa outra coluna o período in. 9:15 fim1. 9:30; indica-me “dentro do previsto” e fora da hr1 “fora do previsto”. e assim tambem na hr2.

    me ajudem!!!!

  23. Cátia Luciana Foss disse:

    Olá.
    É um resultado, em que se for negativo será um débito, e se for positivo um crédito, ou seja lado diferentes de uma planilha (razonete), então para finalizar uma longa planilha preciso do descrito abaixo.
    Se na célula Q101 o valor transportado da I108 for negativo, que seja ele mesmo, do contrário (positivo) que seja zero.
    Se na célula Q101 o valor transportado da I108 for positivo, que seja ele mesmo, do contrário (negativo) que seja zero.
    Obrigada.

  24. Cátia Luciana Foss disse:

    Olá.
    (ERRATA)
    Desculpe-me, mas digitei um endereçamento errado no comentário anterior.
    É um resultado, em que se for negativo será um débito, e se for positivo um crédito, ou seja lado diferentes de uma planilha (razonete), então para finalizar uma longa planilha preciso do descrito abaixo.
    Se na célula Q101 o valor transportado da I108 for negativo, que seja ele mesmo, do contrário (positivo) que seja zero.
    Se na célula S101 o valor transportado da I108 for positivo, que seja ele mesmo, do contrário (negativo) que seja zero.
    Obrigada.

  25. O, Cátia.
    Há um problema na sua lógica…
    Se I108 for negativo, então Q101 = I108, senão Q101 = 0
    Se I108 for positivo, então Q101 = I108, senão Q101 = 0
    Dessa forma o valor resultante sempre seria zero…
    Poderia rever?

  26. Agora, com a errata ficou claro..
    Então vamos lá:
    Em Q101: =SE(I1080<0;I108;0)
    Em S101: =SE(I1080>0;I108;0)

    Abs.

  27. Ola pessoal.
    Tenho uma dificuldade com relação a uma formula que estou tentando inserir em minha tabela.
    estou querendo fazer uma requisição de controle de uniforme onde preencho a planilha de saída e automaticamente gere uma de requisição de retirada para assinatura do colaborador. já tentei esta: =SE(ÉCÉL.VAZIA($G$3);””;SE(ÉERROS(PROCV($G$3;Saidas!$A:$J;5;FALSO));”Produto não cadastrado”;PROCV($G$3;Saidas!$A:$J;5;FALSO)))… mas, nas descrições repete os itens!!!

    obs. se for necessário, envio-lhe a planilha.

    abraço

    jere

  28. Evandro disse:

    Olá a todos!

    Estou com uma planilha de alunos. Onde esses alunos fizeram uma prova, eu preciso marcar com X somente onde eles acertaram. Sendo que cada questão tem um mesmo valor de pontos. Após eu marcar os acertos quero que gere a MÉDIA de cada alunos.

    Caso alguém poder mim ajudar eu agradeço muito…

    Obrigado pela atenção.

  29. Bruna Lima disse:

    Olá, boa noite.

    Pelas dúvidas que li, acho que meu problema não é igual ao de ninguém.

    Preciso que quando o texto inserido em “a1” seja “saída” o valor digitado na célula “h1” se transforme em negativo. Isso porque eu uso a mesma coluna pra valores positivos, ou seja, quando “a2” é “entrada”, o valor fica positivo em “h2” (nisso eu não preciso mexer porque já é automático) e o resultado do meu caixinha é a soma dessa coluna “h”.

    Fui clara? Espero que sim, hehe.

    Alguém pode me ajudar?

  30. Avidelson disse:

    cod KM1 KM2
    104BPE0330 0+000 12+000
    104BPE0350 12+000 19+800
    104BPE0370 19+800 30+500
    104BPE0390 30+500 31+000
    104BPE0410 31+000 43+200
    104BPE0430 43+200 62+200
    104BPE0440 62+200 67+900
    104BPE0445 67+900 71+200
    104BPE0450 71+200 85+600
    104BPE0470 85+600 87+900
    104BPE0490 87+900 106+100
    104BPE0510 106+100 115+200
    104BPE0520 115+200 134+200
    104BPE0530 134+200 138+400
    104BPE0550 138+400 146+700

    Se eu colocar 12+000 em uma celula e 32+100 em outra ele me mostre o cod de 12+00 = 104BPE0350 e os cod entre ou outro 32+100 = 104BPE0410.

    Se entreo intervalo do KM1 ao KM2
    ele me mostre
    = 104BPE0350 / 104BPE0370 / 104BPE0390 / 104BPE0410

    se existe alguma forma de fazer isso, eu agradeço. muito.

  31. William Ww disse:

    Olá, Estou estudando para me aprimorar. E estava com dificuldades em elaborar uma função SE com 3 “argumentos”. E graças a sua explicação EX 2 consegui o resultado esperado! Muito bom e de fácil interpretação; Obrigado e parabéns!!!

  32. salvador buezane disse:

    Boa tarde
    Eu tenho uma coluna com seguintes valores alhetorios
    200
    1000
    -3900
    -200
    -1000

    Eu quero que os valores negativo e posetivo estejam em linhas senguntes, um em cima e outos por baixo;
    Exemplo
    1000
    -1000

    Como poco fazer no excel ??
    Por favor me ajudem;

    Salvador Buezane

  33. Rogger Wilian disse:

    Dúvida, segue o exemplo:

    Célula A1 (Valor 01)
    Célula A2 (Valor 02)
    Célula C3 Resultado do calculo, neste caso uma subtração (A2-A1).

    Pois bem, quando existe dados numéricos em apenas na célula A1, a célula C3 me apresenta o valor da célula A1, porém negativo.

    Gostaria que a célula C3 apresentasse resultados apenas quando as células A1 e A2 fossem preenchidas com números válidos. Ou seja que fique em branco ou que exiba o valor Zero como dado a exibir.

    Como fazer?

  34. Rogger Wilian disse:

    Olá Adilson, obrigado pelo retorno. Tentei executar a formula proposta, no entanto quando existe dados apenas em A1, a célula C3 fica assim: #NOME?

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

w

Conectando a %s

Visitas dos usuários
  • 2,752,273
Drive Virtual

Acesse o link para ter acesso aos arquivos para download.

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.686 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: