0059-Função INDIRETO

Como já vimos no post Criando intervalos dinâmicos, podemos fazer com os intervalos de referência de funções, tabelas dinâmicas e gráficos se ajustem automaticamente à medida que novos dados são inseridos.

Vamos dar uma olhada na função INDIRETO e ver de que forma ela também pode nos ajudar facilitando o ajuste de funções a determinados contextos.

A sintaxe da função é bem simples:

INDIRETO(texto_ref; A1)

texto_ref: cadeia de texto que referencia o intervalo;

A1: define o estilo de referência (VERDADEIRO ou omitido: estilo A1, FALSO: estilo L1C1).

Desta forma, se temos digitado em A1 o valor 2, a fórmula =INDIRETO(“A1”), retorna este valor.

Se tivermos o valor 1 digitado em todas as células do intervalo A1:A10, então =SOMA(INDIRETO(“A1:A10”)).

Você já deve estar começando a se perguntar: Mas e daí? Afinal o mesmo resultado pode ser obtido sem utilizar a função INDIRETO…

Agora vamos à seguinte situação:

Numa pasta de trabalho há uma planilha com o nome de cada vendedor (A, B e C). Nestas planilhas, dentre outras informações, aparece na coluna D o valor das vendas realizadas em cada uma das operações. As planilhas possuem diferentes números de linhas. Como criar uma fórmula que, permita informar o nome do vendedor e obter como resultado o total das vendas realizadas?

Neste contexto vamos utilizar a função INDIRETO na formulação das respostas.
Numa planilha diferente daquelas que contém os dados de vendas e que chamaremos de Resumo vamos colocar em A1 o texto “Nome”. Em B1, faremos a validação do intervalo informando como valores possível A,B e C. Em A2 vamos digitar “Total” e em B2 a seguinte fórmula: =SOMA(INDIRETO(B1&”!D:D”)).

Vimos então que uma fórmula bem simples é possível criar uma forma de consulta bem poderosa.

OBS: No intuito de criar uma fórmula mais genérica, podemos substituí-la por =SOMA(INDIRETO(SE(ÉERROS(LOCALIZAR(” “;B1));B1;”‘”&B1&”‘”)&”!D:D”)). A Justificativa é que quando uma planilha possui espaços na formação do seu nome, uma referência a ela deve ser feita utilizando-se apóstrofos abrindo e fechando o nome. Desta forma, se uma planilha de chama, Plan_Teste, e quisermos referenciar a célula A1, a fórmula é =Plan_Teste!A1. Se o nome for Plan Teste, a referência torna-se ==’Plan Teste’!A1.

Acesse o arquivo e veja o exemplo pronto. Função INDIRETO

Anúncios

In Excel We Trust

Marcado com: , , , , , , , ,
Publicado em Nível: Básico
Um comentário em “0059-Função INDIRETO
  1. R.A.G. disse:

    Muito obrigado, eu não sabia a sintaxe e nem mesmo nos canais mais populares consegui encontrar, felizmente eu encontrei a resposta aqui na sua página. Grato
    R.A.G.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: