0056-Evitando exibição de erros em fórmulas

Tomemos este intervalo de valores como exemplo:

Se colocarmos em F6 o valor 01/02/2011 e tentarmos utilizar a fórmula =PROCV(F6;A1:A20;1;FALSO) veremos que o resultado é um valor de erro #N/D o que significa que o valor não foi localizado.

Podemos evitar que este, e outros valores de erro, apareçam utilizando a função SEERRO.

Vamos reescrever a fórmula: =SEERRO(PROCV(F6;$A$1:$A$20;1;FALSO);”Não localizado”).

Desta forma, se o valor não for encontrado, será exibida a mensagem “Não localizado”.

A função SEERRO foi introduzida a partir da versão 2007. Quem trabalha com versões mais antigas, pode utilizar a função ÉERROS para contornar o problema. A fórmula fica assim:

=SE(ÉERROS(PROCV(F6;$A$1:$A$20;1;FALSO));”Não localizado”;PROCV(F6;$A$1:$A$20;1;FALSO))

Anúncios

In Excel We Trust

Marcado com: , , , ,
Publicado em Nível: Intermediário

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: