0047-PROCV e alternativas para pesquisa

Uma das funções mais utilizadas do Excel é o PROCV.
Sua sintaxe é

PROCV(valor_procurado; matriz_tabela; núm_índice_coluna; procurar_intervalo)
valor_procurado: valor que será pesquisado na primeira coluna do intervalo matriz_tabela;
matriz_tabela: intervalo que contém os dados a serem pesquisados, organizados em colunas e linhas;
núm_índice_coluna: representa a posição da coluna que cujo valor será retornado pela função;
procurar_intervalo: valor lógico que determina se a pesquisa deve ser exata (FALSO) ou aproximada (VERDADEIRO)

Apesar de sua praticidade de uso, o PROCV apresenta algumas limitações:

  • valor_procurado tem que estar na primeira coluna de matriz_tabela. Não há alternativa para pesquisar o valor em outra coluna;
  • Se houver mais de uma correspondência, apenas a primeira é retornada;
  • Não há diferenciação entre letras maiúsculas e minúsculas quando se pesquisa textos

Sobre as limitações acima, já tratamos da 2ª no tópico “Turbinando o PROCV”.

Vamos aqui tratar da segunda, que pode ser resolvida sem a necessidade de VBA ou fórmulas quilométricas.

Utilizaremos duas outras funções, explicadas a seguir:

ÍNDICE(matriz;núm_linha;núm_coluna)
matriz: intervalo de células que contém os dados a serem retornados;
núm_linha: determina qual linha será retornada;
núm_coluna: determina qual coluna será retornada. Se for omitida, assume 1 como padrão.

CORRESP(valor_procurado;matriz_procurada;[tipo_correspondência])
valor_procurado: valor que será pesquisado dentro do intervalo matriz_procurada;
matriz_procurada: intervalo dentro do qual ocorrerá a pesquisa
tipo_correspondência: valor opcional que indica o tipo de correspondência. O valor 0(zero) indica uma correspondência exata.

Vejamos o exemplo a seguir:

O nosso objetivo é determinar em que data ocorreu o valor 2.195. Este valor será inserindo em E1.
Como o PROCV só pode pesquisar um valor, se este localizar-se na primeira coluna do intervalo de dados não podemos utilizá-lo. Alguém poderia dizer que poderíamos então mover a coluna C para a posição da coluna A, mas lembro que muitas vezes isto não é possível ou é desaconselhável.
Vamos primeiramente determinar a linha em que ocorre o valor 2.195 na coluna C. Isto é possível através da fórmula =CORRESP(E1;$C$1:$C$12;0), inserida em E2, e que retorna o valor 6.
Agora utilizaremos a fórmula =ÍNDICE($A$1:$A$12;E2), para retornar o elemento que se localiza na linha 6 da coluna A, que corresponde à data 05/jan.

Entendido o raciocínio, podemos fundir as duas fórmulas numa só =ÍNDICE($A$1:$A$12;CORRESP(E1;$C$1:$C$12;0)).
Desta forma é possível realizar pesquisas em qualquer coluna e retornar o valor de qualquer outra coluna.

Anúncios

In Excel We Trust

Marcado com: ,
Publicado em Nível: Intermediário
Um comentário em “0047-PROCV e alternativas para pesquisa
  1. kio disse:

    Muito legal essas dicas. O Excel é muito abrangente nesse ponto. Obrigado por compartilhar o conhecimento.
    Da uma olhada nesse site tem varias planilhas e modelos pronto pra usar:
    http://www.lojaexcel.com.br
    Gosto bastante desse site!
    Grande abraço

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 2,077,129

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.537 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: