0042-Criando histograma com função de texto

Já pensou em montar um histograma, utilizando caracteres de texto em células ao invés do caminho usual?

Isto é possível utilizando-se a função de texto REPT, para gerar as barras do gráfico.

Partindo de uma tabela de frequências como esta aqui:

Tabela de Frequências

Vamos calcular o total de dados analisados, simplesmente somando as contagens de todas as classes (=SOMA(B2:B10) e definir o caractere de utilizaremos para construção do gráfico. Minha opção inicial é a letra “o”.

Calculando o total e Definindo o Caractere Gráfico

Na célula C2 vamos inserir a fórmula =REPT($B$13;INT(B2/$B$12*100)).

Interpretando a fórmula:

$B$13: Célula que contém o caractere utilizado para construção do gráfico

INT(B2/$B$13*100), parte inteira correspondente à fração que representa a frequência da classe em relação ao total dos dados.

Copiando a fórmula de C2 até a célula C10, obtemos este resultado:

Você pode experimentar outros caracteres como “x”, “§”, etc, ou pode ainda formatar as células $B$13 e $C$2:$C$10 com fontes gráficas como Wingdings e obter resultados como este aqui:

Acesse o arquivo com este exemplo em: Gráfico com Caracteres

Anúncios

In Excel We Trust

Marcado com: , ,
Publicado em Nível: Básico

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: