0002-Criando fórmulas que verifiquem múltiplas condições

É comum utilizarmos a função SE para retornarmos um valor, ou executarmos uma operação tomando como base o atendimento ou não de determinadas condições.
Podemos, por exemplo, definir a fórmula =SE(A1>=7;”Aprovado”;”Reprovado”) para, com base na nota digitada na célula A1, estabelecer se um aluno foi aprovado ou reprovado.
Poderíamos aumentar a complexidade, criando conceitos baseados no valor da nota: =SE(B8>=9;”Excelente”;””)&SE(E(B8=8);”Muito bom”;””)&SE(E(B8=7);”Bom”;””)&SE(E(B8=6);”Regular”;””)&SE(E(B8=5);”Fraco”;””)&SE(E(B8=4);”Muito fraco”;””)&SE(E(B8=3);”Ruim”;””)&SE(E(B8=2);”Muito Ruim”;””)&SE(B8<2;”Péssimo”;””).
Desta forma, se a nota for 8,3, será atribuído o conceito “Muito bom”.
Embora solucione a questão da atribuição dos conceitos, a fórmula é muito extensa e pouco flexível caso desejemos revisar os intervalos de definição de cada conceito.
Para obter a mesma resposta de forma mais simples, lançaremos mão da função PROCV.
Vamos construir a seguinte tabela para parametrizar a fórmula:

A B C
1 Inferior Superior Conceito
2 0 2 Péssimo
3 2 3 Muito ruim
4 3 4 Ruim
5 4 5 Muito fraco
6 5 6 Fraco
7 6 7 Regular
8 7 8 Bom
9 8 9 Muito bom
10 9 10 Excelente

Agora colocando o valor da nota na célula A12 e construir a fórmula: =PROCV(A12;$A$2:$C$10;3;VERDADEIRO).

Comentários:
– O uso do PROCV pode substituir a necessidade de fórmulas complexas para cobrir múltiplas condições
– Além da simplicidade da fórmula resultante, esta abordagem permite uma rápida reconfiguração de valores, bastando para isso alterar os parâmetros diretamente na tabela.

Link para o arquivo: Múltiplas Condições.xls

________________________________________________________________________

Anúncios

In Excel We Trust

Marcado com: , ,
Publicado em Nível: Intermediário

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Visitas dos usuários
  • 2,069,536

Clique para assinar este blog e receber notificações de novos artigos por email.

Junte-se a 1.534 outros seguidores

Aumente sua interação

Siga-nos do twitter (@usuariosdoexcel).

Acesse o nosso fórum e compartilhe as suas dúvidas.

Curta nossa página no Facebook.

Junte-se ao grupo do LinkedIn.

Visite-nos utilizando o seu smartphone ou tablet.

Recomende este Blog
Visualizar notícias
Site monitorado:
Real Time Web Analytics

Clicky

%d blogueiros gostam disto: